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1 Introduction 
 
1.1 Purpose 

 
This document describes how to take a text file describing an amino acid or DNA 

nucleotide and create a model of that amino acid or nucleotide in 3ds max1, using a Max 
script written for that purpose, with animation as desired.  We then describe how to 
export those models into the ShockWave format, and how to then use Director to create 
an animation of the amino acid or nucleotide that can be placed on the web.   
 
1.2 Names and Abbreviations for the Amino Acids 
 

Name   Symbols Formula   
 

1. Alanine  Ala A C3O2N  
2. ARginine Arg R C6O2N4 
3. AsparagiNe Asn N C4O3N2 
4. Aspartic AciD Asp D C4ON4 
5. Cysteine  Cys C C3O2NS 
6. Glutamic Acid Glu E C5O4N 
7. Glutamine Gln Q C5O3N2 
8. Glycine   Gly G C2O2N  
9. Histidine  His H C6O2N3 
10. Isoleucine Ile I C6O2N 
11. Leucine  Leu L C6O2N 
12. Lysine  Lys K C6O2N2 
13. Methionine Met M C5O2NS 
14. Phenylalanine Phe F C9O2N 
15. Proline  Pro P C5O2N   
16. Serine  Ser S C3O3N 
17. Threonine Thr T C4O3N 
18. Tryptophan Trp W C11O2N2 
19. Tyrosine  Tyr Y C9O3N 
20. Valine  Val V C5O2NH11  

 
1.3 Names and Abbreviations for the Nucleotides 
 
1.3.1 The Sugar Deoxyribose 
 
 All nucleotides have in common the sugar and the phosphate group.  The five-
carbon sugar component of DNA (deoxyribonucleic acid) is known as deoxyribose (see 
Figure 1.3-1).  This sugar alternates with phosphate groups to form the “backbone” of the 
DNA polymer.  It binds to the four different nitrogenous bases G, A, C, T shown below.  

                                                 
 
1 AutoDesk 3ds max 8.0, Service Pack 3 
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The binding between the sugar and the phosphate group occurs either with the sugar 5’ 
carbon or with the sugar 3’ carbon, as indicated in the figure.  The bond between one of 
the nitrogen atoms in the nitrogenous base and the sugar occurs at the 1’ carbon. 
 

 
Figure 1.3-1:  Deoxyribose 

 
1.3.2 Guanine (G) 
 
 Guanine consists of the nitrogenous base Guanine (see Figure 1.3-2) with the 
sugar and phosphate group (see Figure 1.3-3 below).  In Figure 1.3-3 the phosphate group 
is bound to the 5’ carbon in the sugar.   

 
Figure 1.3-2:  The Nitrogenous Base Guanine (G) 

 

 
Figure 1.3-3:  Guanine (G) with Phosphate Group 
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1.3.3 Adenine (A) 
 

 
Figure 1.3-4:  The Nitrogenous Base Adenine (A) 

1.3.4 Cystocine (C) 
 

 
Figure 1.3-5:  The Nitrogenous Base Cystocine (C) 

 
1.3.5 Thymine (T) 
 

 
Figure 1.3-6:  The Nitrogenous Base Thymine (T) 
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1.4 Files Used In This Document 
 

This document and the 3ds max files, ShockWave Director files etc. described 
herein can be found in a folder at 

 
http://web.mit.edu/viz/soft/visualizations/biochemistry/

 
Figure 1.4-1 shows the directory structure of that folder.   
 

 
Figure 1.4-1:  The structure of the /viz/soft/visualizations/biochemistry folder 

 
2 The Amino Acid File Format 

 
2.1 Basic File Format:  Example 
  
 The text file below describes the structure of the amino acid Valine.  This file and 
files for the other 19 amino acids can be found in the folder amino_acid_data_files 
described above.  The first line of the file gives the name of the amino acid, the number 
of atoms (19) and the number of bonds (18) for this amino acid.   
 
6 Valine 19 18 
1 C 2.395 -0.117 -0.531   
2 H 2.72 0.05 0.496   
3 H 2.735 0.707 -1.159   
4 H 2.817 -1.052 -0.896   
5 C 0.387 -1.345 0.311   
6 H 0.71 -1.171 1.336   
7 H 0.809 -2.283 -0.05   
8 H -0.702 -1.401 0.278   
9 C 0.866 -0.192 -0.575   
10 H 0.542 -0.366 -1.602   

http://web.mit.edu/viz/soft/visualizations/biochemistry/
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11 H 0.604 1.946 -0.702   
12 O -1.889 2.079 0.266   
13 H -2.818 1.787 0.144   
14 C -1.161 1.05 -0.121   
15 O -1.709 0.038 -0.53   
16 C 0.268 1.128 -0.067   
17 H 0.308 2.283 1.603   
18 H 1.72 1.473 1.303   
19 N 0.7 1.38 1.315   
1 1 2 Single 
2 1 3 Single 
3 1 4 Single 
4 1 9 Single 
5 5 6 Single 
6 5 7 Single 
7 5 8 Single 
8 5 9 Single 
9 9 10 Single 
10 9 16 Single 
11 11 16 Single 
12 12 13 Single 
13 12 14 Single 
14 14 15 Double 
15 14 16 Single 
16 16 19 Single 
17 17 19 Single 
18 18 19 Single 
 
2.2 Information in the File 
 

The information in the file above is used to build the model shown in Figure 2.2-
1, where we have annotated the figure with the numbers of the non-H atoms from the file 
above.  There are a total of eight non-H atoms.  The bonds are drawn using the 
information in the lower half of the file above.  For example, the first bond is between 
carbon atom 1 and hydrogen atom 2, and is a single bond; the 14th bond is between 
carbon atom 14 and oxygen atom 15, and is a double bond.   

 

 
Figure 2.2-1:  Valine 
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The bond colors are determined by the identity of the atoms they connect (red is 
oxygen, blue is nitrogen, dark gray is carbon, and light gray is hydrogen).     
 

3 The Nucleotide File Format 
 
 The files for the nucleotides are very similar in structure to the files for the 
proteins.  The files for the four nucleotides can be found in the folder DNA_data_files 
described above (see Figure 1.4-1). 
 

4 The ConstructAndRotateAminoAcid Rollout 
 

4.1 Creating the Rollout 
 
Go to the templateMaxFiles folder in Figure 1-3.1 and open the .max file entitled 

templateCreateAminoAcid.max.  In the panel on the right hand side click on the hammer 
icon to the far right of the second control bar from the top (see Figure 4.1-2 below).  
Click on the MAXScript label in the Utilities list.  Click on the Open Listener box.  You 
will see a window open up that will show you the progress as you construct your amino 
acid.   

 
Then use the Open Script label under MAXScript to open the script 

constructAndRotateAminoAcid.ms contained in the scripts folder of Figure 1-4.1.  Once 
that file is opened, select the File > Evaluate All command as shown in Figure 4.1-1. 

 

 
 

Figure 4.1-1:  Creating the Rollout 
 

You should now see the screen shown in Figure 4.1-2.  Note that there are a 
number of atoms already present in this file, in a group named individualAtoms.  The 
amino acid we will build always copies the atoms for that amino acid from this group.  
We use different individual atoms depending on whether the atom is in the backbone or 
the side chain.  We do this so that these atoms will have different textures assigned to 
them, so that when we create the ShockWave animation we can make the side chain 
atoms semi-transparent, to distinguish them from the backbone atoms.   
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Figure 4.1-2:  Screen Shot of  templateCreateAminoAcid.max 
 

4.2 Using the Rollout 
 

To open the rollout panel, select ConstructAndRotateAminoAcid under MAXScript 
> Utilities.  Once you have done that you will see the panel shown in Figure 4.2-1.  Click 
on the Select Amino Acid Data File.  A dialog box will open up which will allow you to 
navigate to one of the files contained in the amino_acid_data_files folder.  Let’s assume 
you choose the file named Arginine.txt.  Once you double click on that file you will see in 
the Max Listener window the text 

 
First line of data file selected 
"8 Arginine 26    25" 

 
  
 

 
 



  11 

 
 

Figure 4.2-1:  The Rollout Panel for the ConstructAndRotateAminoAcid Rollout 
If you have gotten the correct file, click on Input/Store Atom/Bond Info.  This will 

read in the data file and display the numbers of the atoms for the various components of 
the amino acid (for example, the number of the carbon alpha atom, and so on).  You then 
have a number of options to choose from.    

 
1. x along c side chain:   

If checked we construct the xyz coordinate axes so that the direction from the 
carbon alpha to the first side chain atom is the x-direction, the y-direction is 
perpendicular to the plane formed by the x-direction and the direction from the 
carbon alpha to the nitrogen atom in the backbone, and the z-direction completes 
the right handed system.  If it is not checked, we construct the xyz axes so that the 
direction from the oxygen with the single bond in the backbone to the nitrogen 
atom in the backbone is the z-direction, the y-direction is perpendicular to the 
plane formed by the z-direction and the direction from the carbon alpha to the first 
atom in the side chain, and the x-direction completes the right handed system.  
The carbon alpha atom is always placed at the origin. 

2. Include Hydrogen Atoms:  
 If checked we include H atoms.   

3. BB and SC Mesh Objects?:  
 If checked, the atoms in the backbone and the side chain are collapsed into mesh 
objects, one for the side chain and one for the backbone.  If not checked, all the 
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atoms are left as individual objects.  For transfer into ShockWave, it is best to 
check this option.   

4. Rotate? (ONLY IF MESH!):   
If checked the amino acid is rotated about its x-axis (if you have chosen the first 
coordinate system above) or about its z-axis (if you have chosen the second 
coordinate system above) with a complete rotation in the number of frames 
specified in the box.  You can only choose this option if you are forming 
meshes.   
 
After choosing your options, click on Process File Using Above.  You should now 

see Figure 4.2-2 in your Perspective window of max.  Note that we have changed the text 
in the amino_acid_name text field in max, so that the text correctly identifies the amino 
acid.   

 
Figure 4.2-2:  The amino acid Arginine as built using constructAndRotateAminoAcid. 
 
 

5 The ConstructAndRotateNucleotide Rollout 
 

5.1 Creating the Rollout 
 
Go to the templateMaxFiles folder in Figure 1-3.1 and open the .max file entitled 

templateCreateDNA.max.  As described in Section 4.1 above, use the Open Script label 
under MAXScript to open the script constructAndRotateDNA.ms contained in the scripts 
folder of Figure 1-4.1.  Once that file is opened, select the File > Evaluate All command 
as shown in Figure 4.1-1. 

 
You should now see the screen shown in Figure 5.1-1.  Note that there are a 

number of atoms already present in this file, in a group named individualAtoms.  The 
DNA we will build always copies the atoms from this group.  We use different individual 
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atoms depending on whether the atom is sugar, the nitrogenous base, or the phosphate 
group.  We do this so that these atoms will have different textures assigned to them, so 
that when we create the ShockWave animation we can make the various groups of atoms 
semi-transparent with different levels of transparency, to distinguish them from the other 
groups of atoms.   Typically we have the nitrogenous base atoms totally non-transparent, 
the sugar atoms at 50% transparency, and the phosphate group atoms at 30% 
transparency in the ShockWave.   

 

 
 

Figure 5.1-1:  Screen shot of templateCreateDNA.max 
 
5.2 Using the Rollout 

 
To open the rollout panel, select ConstructAndRotateDNA under MAXScript > 

Utilities.  Once you have done that you will see the panel shown in Figure 5.2-1.  Click 
on the Select DNA Data File.  A dialog box will open up which will allow you to 
navigate to one of the files contained in the DNA_data_files folder.  Let’s assume you 
choose the file named Thymine.txt.  Once you double click on that file you will see in the 
Max Listener window the text 
 
First line of data file selected  

"7 Thymine 37    38" 
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Figure 5.2-1:  The Rollout Panel for the ConstructAndRotateDNA Rollout 
 

If you have gotten the correct file, click on Input/Store Atom/Bond Info.  This will 
read in the data file.  You then have two options to choose from.    

 
1. Mesh Object?:  

 If checked, the atoms in the molecule are collapsed into one mesh object.  If not 
checked, all the atoms are left as individual objects.  For transfer into ShockWave, 
it is best to check this option.   

2. Rotate? (ONLY IF MESH!):   
If checked the amino acid is rotated about its z-axis, which is an axis more or less 
perpendicular to the plane of the nitrogenous base(s) in the DNA.  You can only 
choose this option if you are forming a mesh.   
 
After choosing your options, click on Process File Using Above.  You should now 

see Figure 5.2-2 in your Perspective window of max.  Note that we have changed the text 
in the DNA_name text field in max, so that the text correctly identifies the molecule.   
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Figure 5.2-2:  The nucleotide Thymine as built using ConstructAndRotateDNA. 

 
 
 

6 Creating a ShockWave Animation for an Amino Acid 
 
6.1 Exporting the .W3D ShockWave File From Max 
 
 We explain how to export using the amino acid Arginine created in Section 4.2 
above.  We assume you have the 3ds max file open and have created the Arginine amino 
acid as shown in Figure 4-2.2.  Make sure your active viewport is Perspective and not 
any other viewport (e.g. front), otherwise your amino acid will export in a “flat” 
orthographic projection.  Delete the individualAtoms group.   
 
 Now look at your amino acid in the Perspective viewport, and make sure that 
when it rotates (if you have chosen rotation), you can see all of the atoms of the amino 
acid at every part of the rotation, and that the amino acid fits into the window in a 
reasonable way (e.g. it does not appear small in the viewport).   
 
 Go to File > Export.  In the Select File to Export dialog box that comes up, chose 
ShockWave 3D Scene Export (*.W3D).  Choose the file name arginine.W3D.  Take all the 
standard options in the Shockwave 3D Scene Export Options dialog box.  Export the file.   
 
6.2 Importing the .W3D File into a Director .dir File  
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 Go to the folder templateShockWaveFiles and open the Director File 
templateAminoAcidDirector.dir.    You will see something resembling Figure 6.2-1.  If 
you do not see the Cast and Stage windows, go to Window in the main toolbar and select 
them.   We have already imported the Methionine .W3D file into this Director file.  If you 
hit the “play” icon in the upper tool bar of Director, this animation will play.  Hit pause.  
We will now show you how to replace Methionine with Arginine.   
 
 Left click on the methionine in the Cast window, and hit delete.  Chose File > 
Import, navigate to where you stored the arginine.W3D file, and import it.  After you do 
this, it will now appear in the Cast window.   Double left click on the initialize script in 
the Cast window to open that file.   

 

 
 

Figure 6.2-1:  The Director Window for Methionine 
 
In the fourth line down in that file, you will see a line: 

 
scene = member("methionine") 

 
Change the methionine to arginine.   Navigate a little further down in the initialize file 
until you come to:   
 
   scene.shader("bondSC").blend = 50 
   scene.shader("carbonSC").blend = 50 
   scene.shader("hydrogenSC").blend = 50 
   scene.shader("sulfurSC").blend = 50 
   --  scene.shader("oxygenSC").blend = 50  
   --  scene.shader("nitrogenSC").blend = 50  
  
For methionine, the side chain only has carbon, hydrogen, and sulfur atoms, so we cannot 
set the transparency of oxygen and nitrogen—thus these statements are commented out 
above (--).  For arginine, the side chain has carbon, hydrogen, and nitrogen, and no sulfur 
or oxygen, so the statements above should be changed to: 
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   scene.shader("bondSC").blend = 50 
   scene.shader("carbonSC").blend = 50 
   scene.shader("hydrogenSC").blend = 50 
   -- scene.shader("sulfurSC").blend = 50 
   -- scene.shader("oxygenSC").blend = 50  
   scene.shader("nitrogenSC").blend = 50  
   
Then hit the “lightning” symbol in the tool bar of the edit window for initialize to save 
these changes.   
 
 Finally, left click in the Stage window on the panel containing the arginine 
model.  Make sure you have your Window > Property  Inspector window open, and in 
the tabs at the top of that window, choose Behavior.  You will see Figure 6.2-2.  Double 
left click on OrbitEDIT, and choose parameters.  In the dialog box that comes up, choose 
ARG_backbone.  If you now hit “play” in the upper tool bar (see Figure 6.2-1 ), you 
should now see the arginine model animating.  If you left click in the player window you 
can change perspective.   
 

 
 

Figure 6.2-2:  The Director Property Inspector window. 
 
6.3 Publishing the Animation on the Web 
 
 Go to File > Publish.  This will create a ShockWave .dcr file.  This can be 
referenced in an .htm document such as the one found in your templateShockWaveFiles 
folder, and will play over the web.  When you create the .dcr file, it will open a web 
browser and play a preview of the animation.   
 
 

7 Creating a ShockWave Animation for a DNA Molecule 
 
7.1 Exporting the .W3D ShockWave File From Max 
 
 We explain how to export using the nucleotide Thymine created in Section 5.2 
above.  We assume you have the 3ds max file open and have created the Thymine as 
shown in Figure 5-2.2.  Make sure your active viewport is Perspective and not any other 
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viewport (e.g. front), otherwise your molecule will export in a “flat” orthographic 
projection.  Delete the individualAtoms group.   
 
 Now look at your molecule in the Perspective viewport, and make sure that when 
it rotates (if you have chosen rotation), you can see all of the atoms of the molecule at 
every part of the rotation, and that the molecule fits into the window in a reasonable way 
(e.g. it does not appear small in the viewport).   
 
 Go to File > Export.  In the Select File to Export dialog box that comes up, chose 
ShockWave 3D Scene Export (*.W3D).  Choose the file name thymine.W3D.  Take all the 
standard options in the Shockwave 3D Scene Export Options dialog box.  Export the file.   
 
7.2 Importing the .W3D File into a Director .dir File  
 
 Go to the folder templateShockWaveFiles and open the Director File 
templateDNADirector.dir.    You will see something resembling Figure 6.2-1.  If you do 
not see the Cast and Stage windows, go to Window in the main toolbar and select them.   
We have already imported the adenine .W3D file into this Director file.  If you hit the 
“play” icon in the upper tool bar of Director, this animation will play.  Hit pause.  We 
will now show you how to replace Adenine with Thymine.   
 
 Left click on the adenine  in the Cast window, and hit delete.  Chose File > 
Import, navigate to where you stored the thymine.W3D file, and import it.  After you do 
this, it will now appear in the Cast window.   Double left click on the initialize script in 
the Cast window to open that file.  In the fourth line down in that file, you will see a line: 

 
scene = member("adenine") 

 
Change the adenine to thymine.   For the DNA files, you do not need to change any of the 
transparencies in the initialize file, e.g.  
 
     scene.shader("Osugar").blend = 50 
   
unless you want to change the basic level of transparency.  Then hit the “lightning” 
symbol in the tool bar of the edit window for initialize to save the changes.   
 
 Finally, left click in the Stage window on the panel containing the thymine  
model.  Make sure you have your Window > Property  Inspector window open, and in 
the tabs at the top of that window, choose Behavior.  You will see something similar to 
Figure 6.2-2.  Double left click on OrbitEDIT, and choose parameters.  In the dialog box 
that comes up, choose T  If you now hit “play” in the upper tool bar (see Figure 6.2-1 ), 
you should now see the Thymine model animating.  If you left click in the player window 
you can change perspective.   
 
 
7.3 Publishing the Animation on the Web 
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 Go to File > Publish.  This will create a ShockWave .dcr file.  This can be 
referenced in an .htm document such as the one found in your templateShockWaveFiles 
folder, and will play over the web.  When you create the .dcr file, it will open a web 
browser and play a preview of the animation.   
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