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DOWNLOADING STANDARD REPORTS IN BRIO QUERY VERSION 6 
 
Downloading a standard report template is easy.  On the Data Warehouse home page, find the 
Reports section: you will see several choices.  Click on the link to the business area that you 
want.  Production Directory and Web Statistical Reports are in the General report area.  You will 
see that the report templates are subdivided them into areas named “Employee Directory, 
“Keys,” and “Web Statistics.”  Clicking on “Web Statistics” will jump you to the reports related 
to Web Statistics.  You could also scroll through the page until you come to the reports you 
want; the page is alphabetical by subarea.  Each report has a brief description of its purpose to 
help you decide which one you want to look at. 
 
When you find a report you want to download. click on“PC6” or “Mac6” (or “PC5” or “Mac 5” 
for older reports) under the report name, depending on your platform. 
 

NOTE:  All new reports will be available ONLY in BrioQuery version 
6.  We will leave existing version 5 reports on the web for an overlap 
period to enable users become comfortable with version 6. 

 
Both PC and Mac templates work on both platforms; the difference is that the fonts and margins 
are formatted to look and print best on the specific platform, since the same font and font size 
looks very different on a Mac monitor than a PC monitor, and pages also print differently. 
 
Important note to Mac OS X users:  Brio does not have a desktop version for Mac OS X.  Mac 
OS X users should use Citrix (see Appendix 2), a PC emulator which allows you to run the PC 
version of Brio on MIT’s Citrix server on your OS X Mac.  You should download the PC 
version, rather than the Mac version, of query templates from the warehouse web pages for use 
via Citrix. 
 
Below you will find instructions for downloading canned report templates from the Data 
Warehouse: 
 
From the Data Warehouse home page, click on the business area, in this case General. 
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The Data Warehouse Home Page: click on “Human Resources” under reports. 

 
This takes you to the page of General reports: 
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Downloading a Report:  Click on “PC6” or Mac6” under the report name 

 
When you click on Mac 6 or PC6, the “Downloading…” dialog box opens (Netscape 7): The 
radio button “save this file to disk” should be checked by default; if not, check it. 
 

 
The Netscape 7 “Download” dialog box 
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In the next box, navigate to the folder in which you wish to save the template: 
 

 
The “Save As…” Dialog box 

1. Choose the Directory folder in which you want the report to be saved. 

2. Click on the Save button. The report icon appears on your desktop.   
3. To open the report, just doubleclick on it. 

Note: Mac OS X users will find that the downloaded template is a blank white icon or an icon 
looking like an Excel icon, rather than an icon with the BrioQuery blue, green and red colors.  
Citrix will recognize this as a BrioQuery document.  If you are using the desktop version of 
BrioQuery under Classic (OS 9.2) on your Mac OS X computer, you will not be able to open the 
template by doubleclicking on it.  In this case, you should open the Brio Query application and 
use File --> Open to open the template. 
 
Note: By default, the Brio “File Open..” command looks for files of type Brio Intelligence.  Be 
sure to change this to “All Files (*.*)” in the dialog box that opens so that you can find the file: 
 



  Introduction to the MIT Data Warehouse 

 
Page 7 of 22 

 
The “Open File” dialog box with Files of type: All Files (*.*) selected 

 
THE BRIO QUERY V.6X ENVIRONMENT 
Those of you who have used BrioQuery version 5 will see that BrioQuery version 6 has a 
different look and feel, but the process of looking at the data in today’s class should familiarize 
you with the new look.  A summary of the BrioQuery v.6 menus, toolbars, and sections is in 
Appendix 3 at the end of this document. 
 
When you open a report template, it will open to the Query section: 
 

 
PROCESSING STANDARD REPORTS  

1. To run a report you have downloaded and receive results from the database, press the 
“Process” button at the top of your screen.   
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2. You will be prompted to log on to the warehouse. If needed, select the OCE (open 
catalog extension) named warehse.oce.  You will need to enter your username (your 
Kerberos ID) and the warehouse password you chose when you received authorization to 
use the warehouse. 

 
The log on box 

Note: if you have forgotten your Data Warehouse password, you can change your password 
without knowing the old one by going to http://web.mit.edu/warehouse/change_password.html or 
by clicking on the Change Password link under Web Functions on the Data Warehouse home 
page. 
 

3. Depending on the report you are processing, you may be prompted to enter one or more 
limits.  In the dialog box that appears, a short text message is displayed to assist you with 
your limit selection.  In today’s example, we will be asked to select a Department Name 
for your directory reports.  We will to ask for Department Name Equal to Information 
Services & Technology. This should return all employees that have their directory 
department set to Information Services & Technology. 

 
The Limit Box 

4. Once results are retrieved you will be automatically transferred to the “Results” section, 
where you may view your results.  You will see many rows of information.  This is your 
raw (unformatted) data: 
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The Results Section 

 
You may export your Results, or any section other than the Query section, to Microsoft Excel, 
HTML, or a text file if you want to combine it with other local data.  To do this, you must be in 
the section you wish to export: for example, Results. 
 

 
The File >> Export >> Section path 
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1. From the File Menu, choose Export --> Section.  When the Export section dialog box 
opens, choose the desired export format from the “Save as type” dropdown list, navigate 
to the folder in which you want to store the export, and click Save.  The export happens 
instantly. 

 

\  
The Export Section Dialog Box 

 
There will also be one or more pre-formatted reports in any query document that you download 
from the Data Warehouse reports page. 
 

 
A formatted Report section 

 
To create a report, field names are dragged from the lower pane of the section catalog into what 
Brio calls the Outliner (for Pivot reports, Tables, and Charts) or the “Groups” and “Tables” 
boxes (Report Generator reports).   
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The Report section outliner boxes 

The Groups section contains the major categories of your report – the levels at which any 
numerical data, for example, headcounts, could be subtotaled and totaled.  The Tables 
Dimensions box contains the fields that serve as “labels” and the Tables Facts box contains the 
data items that will be subtotaled or be used in calculations. 
 
Pivot Reports 
 

 
Example of a Pivot Report 

Notice that the Outliner looks a little different than the “Report” outliner. 
 

1. The “Side Labels” box contains the fields that comprise the columns to the left of the data 
section. 

 
2. The “Top Labels” box contains the fields that provide the category headers for the fields 

placed in the Facts box: 
 

3. The “Facts” box contains the fields of numerical data – Count of Employees by Directory 
Title  (this is actually the count of Names), or other fields that will be totaled or counted. 
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USING BRIOQUERY VIA CITRIX ON MAC OS X MACHINES 
 
BrioQuery does not have a desktop version for Mac OS X machines.  Citrix is a PC emulator that 
allows you to run the PC versions of MIT’s enterprise applications on your Mac OS X.  In 
addition to BrioQuery, you can also run Coeus, Adonis, Roles, SumMIT and SAP via Citrix. 

You must register for Citrix before you can install and use it.  To register for Citrix, go to 
https://citrix.mit.edu/register (MIT certificates required). 

Full instructions for installing Citrix are on the Citrix home page at 
https://citrix.mit.edu/citrix/install.html (MIT certificates are required); these instructions also 
appear below for your convenience. 

Note: To use Citrix, your Kerberos password cannot be more than three years old.  If your 
kerberos password exceeds this age limit, you need to change your Kerberos password.  Mac 
OS X users can do this by opening the Utilities folder in the Applications folder, scroll until 
you find the Kerberos icon, double-click on it to open it, and click on “Change Password.” 

 
Installing Citrix 
 
After you have registered for Citrix, 

1. Go to http://citrix.mit.edu/ 
Result: The Citrix Welcome page displays. 
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2. Click the ICA web client for MacOS X systems icon over to the right under the 
“Metaframe XP Message Center” heading. 
Result: The Downloading MacICA_OSX_dmg.zip window displays. 

 

3. Select Open using StuffIt Expander and click OK. 
Result: The folder MacICA_OSX_dmg and the file MacICA_OSX_dmg.zip will appear 
on the desktop. 

 

4. Double-click the MacICA_OSC_dmg folder.  
 
Result: The folder will open. 

 

5. Double-click MacICA_OSX.dmg (the one with the hard drive icon). 
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Result: The Citrix ICA client folder will open,  

 

and a Citrix ICA Client volume will be mounted on the desktop. 

 

Drag the Citrix ICA Client folder icon from the open folder window to your hard drive: 

 

Result: The Citrix folder will now appear in the hard drive.  You may wish to put it in your 
Applications folder. 
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6. Close all windows that have been opened during the Install process. 

7. Drag the following files/folders (created during the Install) to the Trash: 

   MacICA_OSX_dmg folder 
   MacICA_OSX_dmg.zip 
   Citrix ICA Client mounted volume 

 

Result: The files that are no longer required will be deleted. 

8. Open your browser, and go to http://citrix.mit.edu/ 
Result: The Citrix welcome page will appear; your username should be displayed in the 
Login box. 

 

9. Click Login. 

10. Result: The Citrix Applications page will appear. 
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11. Select one of the applications by double clicking on its icon, for example BrioQuery. 

Note: You will only be able to access applications for which you are authorized. 
Result: The first time you use Citrix, the Citrix Client Software License Agreement will 
appear. 

 

Click Accept. 
Result: A connection will be made to the Citrix Server. The Windows2000 Advanced Server Log 

on screen appears. 
 
 

 
 

12. Enter your Kerberos user name and password and click OK. 
Result: The application you selected will open.  

When using BrioQuery via Citrix on a Macintosh, you are actually using BrioQuery for 
Windows and not BrioQuery for the Mac.  BrioQuery for Windows is the same as 
BrioQuery/Macintosh as far as features and commands; however there are some differences 
since you are accessing BrioQuery via Citrix.  Below are differences you will encounter: 

Downloading BrioQuery templates: 
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Since you'll be using BrioQuery 6 for Windows via Citrix, be sure to download the PC6 versions 
of BrioQuery templates from the Data Warehouse web site.  Mac versions may not look as  

Changing the window size:  

BrioQuery in the Citrix window cannot be maximized to the fill the screen by using the + sign in 
the upper left corner of the Citrix window or by using the Maximize button in the top right 
corner of the BrioQuery application window. If you want to make the window larger, do the 
following: 

Go to the Citrix home page and log in. 

 
The Citrix Home page 

In the Applications area under "Citrix MetaFrame XP" click on the Tools icon:  

Result: The Settings dialog box displays. 

 
The Citrix Settings Page 
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Under "Connection Preferences: Window size" specify a custom size: Mac BrioQuery 
users should set a custom size of 1024 x 768. 

Click Submit. (Note: If the Submit button doesn't appear in the window, use the scroll 
bar on the right side to scroll to the bottom.) 

Back in the Applications area, click on the BrioQuery icon to download the .ica file you'll 
use to launch BrioQuery via Citrix. (If you've previously downloaded a launch.ica file, 
replace it with a new one to retain the changes you just made.) 

Result: When you double-click on the .ica icon, Citrix launches and a window displays at 
the size you specified.  Any time you want to change the window size, repeat steps 1 – 5 
and save a new ica. 

Keyboard shortcuts 

Since you're running BrioQuery for Windows, make sure you use the BrioQuery (Windows) 
keyboard shortcuts rather than the BrioQuery (Macintosh) shortcuts. For example, to open a file, 
press <control>-O. 

CONTEXT-SENSITIVE MENUS 
To access the BrioQuery context-sensitive menus, place your pointer on the item, then press 
<option>-click. 

Opening and saving files 

The Open and Save dialog boxes do not display the name of your local hard drive(s) but instead 
display drive letters and terms used in Windows 2000, e.g., Local Disk [C:].  Your desktop hard 
drive is the “V” drive.  One of the items in the popup list in the Open or Save dialog box (C$ on 
'Client'[V:]) gives you access to your account folder inside the Users folder on your startup 
drive. You'll need to store any BrioQuery files you download or create inside this folder in order 
to open them in BrioQuery via Citrix. 

To open or save a file, do the following: 

Go to either File>Open... or File>Save As....  

Result: A message displays, "Program requires READ access to the "C" drive which 
maps to the folder hdname:Users:user_folder (where hdname is the name of your hard 
drive and user_folder is the name of your account folder in the Users folder). Do you 
want to allow or deny READ access to this folder for the rest of the session?"  

Click Allow.  

Result: The Open or Save As dialog box displays.  

Click on the arrow to the right of the Program folder and select C$ on 'Client'[V:] from 
the list to go to your local hard drive.  

Result: The folders inside hdname:Users:user_folder display.  

Save the file. 
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Note: You can't freely navigate your hard drive through the Open or Save As dialog boxes so 
you may want to keep all BrioQuery files inside your account folder inside the Users folder.  
You may want to create a subfolder specifically to store your BrioQuery files.  Otherwise you 
will have to navigate through C$ on 'Client'[V:] for each document. 

 
PRINTING 
You need to go through some additional dialog boxes to print, unlike when you print using a 
Macintosh program on your local machine. To print, 

In BrioQuery, go to File>Print… 

Result: The BrioQuery (Windows) dialog box displays. 

Click OK.  
Result: The Macintosh Print dialog box displays. 

Note: If the Macintosh Page Setup dialog box displays, choose your printer from the Format 
for: popup list, then click OK. 

From the Print: popup list, choose your printer, then click Print. 

Important Note:  You may find that you cannot use “advanced” page setup functions (changing 
from portrait to landscape, scaling).  We’ve been told that an up-coming release from the vendor 
will fix this limitation, after which printing to your local printer with the full functionality of 
your printer’s capabilities should be seamless.  Meanwhile, although non-ideal, there is a 
temporary fix available.  You will need to register your printer on the Citrix server.  To do this, 
send your request to system-citrix@mit.edu.  They will need to know the zone you are in, the 
make and model number of your printer, and its IP address (if your printer has a unique name 
that appears in your local printer list, rather than the generic model name, you can put your 
printer’s name in the message rather than its IP address). 

Note to new Mac OS X users: you will find the Print Center application in the Utilities folder 
in the Applications folder on your OS X.  This replaces the OS 9 Chooser for setting up 
printers. 
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APPENDIX 1: BrioQuery v.6 Menu Bar and Toolbars 
 
The Menu Bar: 
 
The first five categories on the menu bar will be familiar to you from other applications, as will 
the Window menu: 
 
File File management tasks such as New Query, Open, Close, Save, Print, and most 

recently used list of queries.  The “Save Options” allows you to choose whether 
to save your query results when you save your document. 

Edit The familiar Cut, Copy, Paste options, and options to Delete, Rename, or 
Duplicate a section. 

View From the View menu you can toggle on and off the display of the Standard, 
Formatting, and Section toolbars, the Section Catalog panes, the Section Title 
Bar, and the Status Bar. 

Insert Insert new sections 
Format Formatting font and number 
Window Lets you toggle between open BrioQuery documents 
 
The Query, Data Model, and Tools menu commands are more specific to BrioQuery documents.  
Some highlights are: 
Query Estimate Query Size will tell you how many rows of data will be returned when 

the Query is processed. 
Data 
Model 

Query Options lets you instruct Brio to bring back only a small number of rows 
if you aren’t sure what you will be bringing back and want to see before 
bringing back a larger result set. 

Tools Lets you customize default formatting options, and instruct Brio to remember 
your user name after the first time you log on (see Note box to set your user 
name as the default user name). 

 
The Standard Toolbar: 
 

 
 
The first five buttons are familiar file management tools: New Query, Open, Save, Print, and 
Print Preview.  The sixth button is the remove button and duplicates the action of the Delete key.   
The remaining buttons may be active or inactive depending on the item selected. 
 
The Formatting Toolbar: 
 

 
 
The tools in the formatting toolbar should also be familiar from other software products such as 
Microsoft Office; they are used to format and align text in reports. 
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The Section Title Bar: 
 
The Section Title Bar is where you turn on and off your limit and sort lines, your Outliner, etc.  
What you see in the Section Title Bar is context sensitive, i.e., you have different options 
depending on what section you have active:  two examples are shown below.  The Query section 
title bar lets you toggle on and off the Request, Limit, and Sort lines, and also shows you how 
many items you have in each.  The Results section title bar lets you toggle on and off a limit line, 
a sort line, and an Outliner box. 
 

 
 

 
 
The Section/Catalog: 
 
This area replaces both the Brio 5 section tabs and its free-floating Table Catalog.   The 
BrioQuery Section/Catalog panes can be toggled on and off from the View Menu.  The top pane 
lists all of the Sections in your BrioQuery document: the Query section, Results section, and any 
preformatted report sections.  For those of you familiar with BrioQuery version 5.x, this section 
catalog replaces the Brio version 5 section tabs at the bottom of the window.  The lower pane is 
the Data Warehouse Table Catalog, which is no longer a free floating window as it was in 
BrioQuery version 5.x.  The table names you see will depend on the warehouse business areas 
you are authorized to see. 

 


